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This how-to describes how to set up a Grouper development environment so that you can code, test, and debug Grouper. This how-to is specific to 
Grouper 2.4. Instructions for Grouper 2.5 are over at  . How to Setup a Grouper Development Environment for Grouper v2.5

The example commands and screenshots are from MacOS and Eclipse, and may vary slightly for different environments. However, the overall process 
should be similar on any modern operating system and development tool chain. Developers can use whatever tools that let them work most efficiently.

Prerequisites

Git for source code version control

Install Git

Command line installs

$ brew install git
https://github.com/fabriziocucci/git-bash-for-mac
Or Install from package https://git-scm.com/downloads

Eclipse IDE plugin
https://www.eclipse.org/egit/

Github Desktop is also handy

Java - Grouper runs on Java

Install OpenJDK 8 or above. Grouper runs on Java.

https://aws.amazon.com/corretto/
Note: do not use Java language features above Java 8 for most of Grouper - grouper, grouper-ui, grouper-ws, etc. The grouperClient code must 
be compliant with Java 6.

Apache Tomcat - Grouper runs in Tomcat

Download and unpack Tomcat 8.5.x
https://tomcat.apache.org/download-80.cgi

Docker Desktop - to run our development database

Install Docker Desktop. We’ll use this to run our development database.
https://www.docker.com/products/docker-desktop

Eclipse - Grouper development happens in Eclipse (or your favorite IDE)

Install Eclipse IDE for Enterprise Java Developers or similar IDE
https://www.eclipse.org/downloads/packages/

Clone the Grouper Source Repository

The Grouper source code repository is managed in GitHub at .https://github.com/Internet2/grouper

git clone --branch GROUPER_2_4_BRANCH   https://github.com/Internet2/grouper.git grouper-2.4
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Note: The build strategy changed for the 2.5 release. Switching between 2.4 and 2.5 branches in the same directory and workspace when developing is 
not recommended. Instead, keep 2.4 and 2.5 work in separate local directories each with their git repository and their own eclipse workspace. For 2.5 
development see  .How to Setup a Grouper Development Environment for Grouper v2.5

Import Projects into Eclipse

Start a new eclipse workspace and import grouper modules as individual projects. Project will import as Maven projects and automatically download the 
required Maven dependencies. The example commands below assume the git repository was cloned to the local directory '/Users/thompsow/src/grouper-
2.4/'.

Make a variable for the root of the git repo called GIT_ROOT: e.g. for /Users/thompsow/src/grouper-2.4
Import grouperClient

Eclipse -> File -> Open Projects for File System or Archive
Import source: ${GIT_ROOT}/grouper-misc/grouperClient

Import the grouper
Eclipse -> File -> Open Projects for File System or Archive
Import source: /Users/thompsow/src/grouper-2.4/grouper

Import grouper-ui
Eclipse -> File -> Open Projects for File System or Archive
Import source: /Users/thompsow/src/grouper-2.4/grouper-ui

Import grouper-ws
Eclipse -> File -> Open Projects for File System or Archive
Import source: /Users/thompsow/src/grouper-2.4/grouper-ws/grouper-ws

All the project should now be open and compiled.

Link source and conf to grouper project

We want to be able to run and debug the Grouper so that it picks up client source changes as you develop.

Add dependent source and configuration folders to the grouper-ui Java Build Path
Add grouperClient src

Click ‘Link Source…’
Click ‘Variables…’
Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper-misc/grouperClient/src/java
Folder name: grouperClient-src

Add grouperClient conf
Click ‘Link Source…’
Click ‘Variables…’
Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper-misc/grouperClient/conf’

https://spaces.at.internet2.edu/display/GrIntDev/How+to+Setup+a+Grouper+Development+Environment+for+Grouper+v2.5
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Folder name: grouperClient-conf

Link source and conf to grouper-ui project

We want to be able to run and debug the Grouper UI from the grouper-ui/webapp folder, so that we can work on webapp artifacts (JSPs, etc), and at the 
same time update Java code in the grouper project and other code locations. To do this we will update the Java Build Path output folder so that compiled 
classes and other artifacts go to the right directories under grouper-ui/webapp. We will also add some dependent source and library folders to the grouper-
ui Java Build Path.

grouper-ui -> File -> Properties -> Java Build Path -> Source tab
Set ‘Default output folder:’ to: grouper-ui/webapp/WEB-INF/classes (you may have to create this directory)

Add dependent source and configuration folders to the grouper-ui Java Build Path
Add grouper conf

Click ‘Link Source…’
Click ‘Variables…’
Click ‘New…’

Name: GROUPER_REPO
Click ‘Folder…’ and select the root repo folder

Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper/conf’
Folder name: grouper-conf

Add grouper src
Click ‘Link Source…’
Click ‘Variables…’
Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper/src/grouper’
Folder name: grouper-src

Add grouperClient src
Click ‘Link Source…’
Click ‘Variables…’
Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper-misc/grouperClient/src/java
Folder name: grouperClient-src

Add grouperClient conf
Click ‘Link Source…’
Click ‘Variables…’
Select GROUPER_REPO
Click ‘Extend…’
Select ‘grouper-misc/grouperClient/conf’
Folder name: grouperClient-conf

Make sure all folders except ‘grouper-ui/java/test’ are using the default output folder
Make sure grouper-ui/conf has ‘Excluded:’ set to (None)
Remove srcPoc and misc source folders (these are not needed)

The grouper-ui Java Build Path should now look something like this:

Add runtime jars to grouper-ui Java Build Path

We need to pull dependent jar files into grouper-ui/webapp/WEB-INF/lib directory. We’ll do this by adding three more “source” folders to the grouper-ui 
Java Build Path.

grouper-ui -> File -> Properties -> Java Build Path
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Add grouper jars
Link Source…

Linked folder location: GROUPER_REPO/grouper/lib/grouper
Folder name: grouper-lib

Configure grouper-lib source to output to path relative to ‘grouper-ui’
Check “Allow output folders for source folders
Click “Output folder” on grouper-lib
Select ‘Specific output folder (path relative to ‘grouper-ui’)

create/select ‘webapp/WEB-INF/lib’
Add jdbc sample jars

Link Source…
Linked folder location: GROUPER_REPO/grouper/lib/jdbcSamples
Folder name: jdbcSamples-lib
Configure jdbcSamples-lib source to output to path relative to ‘grouper-ui’

webapp/WEB-INF/lib
Add grouper-ui jars

Add Folder…
Select java/lib
Check “Allow output folder for source folders
Configure grouper-lib source to output to path relative to ‘grouper-ui’

webapp/WEB-INF/lib
Add javax.servlet.jsp-api.{version}.jar to Exclusion patterns

The grouper-ui Java Build Path should now look something like this:

Configure Eclipse Code Formatter

Eclipse -> Preferences -> Java Code Style -> Formatter
Import… (navigate and select ../grouper-2.4/grouper/misc/eclipse/fastFormat.xml)
Apply and close

Development Database
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Multiple databases are supported including Oracle, mySQL, and PostgreSQL. We’ll use PostgreSQL for this how-to. The steps for other databases would 
be similar.

Start the development database

We will run postgres with a mounted external volume to preserve data between docker container restarts.

Create a named volume 'docker create volume grouper-postgres'
Run ‘docker run --name grouperdb -e POSTGRES_PASSWORD=grouper -e POSTGRES_USER=grouper -d -p 5432:5432 -v grouper-postgres:

 postgres’/var/lib/postgresql/data

Connect to development database in Eclipse

Window -> Perspective -> Open Perspective -> Other -> Database Development -> Open
Right click ‘Database Connections’ and create PostgreSQL connection profile
Add the postgess JDBC driver found in under ../grouper/grouper-ui/webapp/WEB-INF/lib/
Enter the connection details and then click Test Connection

Configure minimum properties files for development

Create and configure the grouper-hibernate.properties for postgres

cd ../grouper-2.4/grouper/conf
cp ../misc/grouper.hibernate.example.properties grouper.hibernate.properties  
Edit ../grouper/grouper/conf/grouper.hibernate.properties

Running Postgres in Docker on a Windows Host

Postgres' docker image runs the database as an unprivileged user   The container's startup script attempts to chown /var/lib/postgresqlpostgres.
/data folder to this user. In Docker Desktop for Windows, this causes the script to throw an error and exit.  Bind volumes cannot easily have their 
ownership changed from within the container running on a Windows host.  The workaround for this is creating a named volume instead.

http://postgres/var/lib/postgresql/data
http://postgres/var/lib/postgresql/data
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Create and configure morphString.properties

cd .../grouper-2.4/grouper/conf
cp .../misc/morphString.example.properties morphString.properties  
Edit .../grouper/grouper/conf/morphString.properties
encrypt.key = not_a_random_key

Create remaining required properties files

All of the *.base.properties in grouper/conf need to be copied to *.properties files in the same directory.

Also need to copy .../grouper/conf/grouperText/grouper.textNg.en.us.base.properties to grouperText/grouper.text.en.us.properties.

Bootstrap the Grouper Database

For development purposes, we’ll bootstrap the Grouper database, add sample subjects, and reset the database using a few Java classes.

Run GrouperShell from Eclipse to initialize the Grouper database:

Right click GrouperShell in the Grouper project explorer
Select ‘Run as’ and then ‘Run Configurations…’
Name: GrouperShell -registry -runscript -noprompt
(x) = Arguments tab

Program arguments: -registry -runscript -noprompt
Classpath tab

Highlight User Entries and click ‘Advanced…’
Add the ‘conf’ folder to the classpath for the properties files

Click ‘Apply’
Click ‘Run’

Run GrouperShell from Eclipse to check the Grouper database:

Right click GrouperShell in grouper project explorer
Select ‘Run as’ and then ‘Run Configurations…’

Name: GrouperShell -registry -check -noprompt

http://grouper.textNg.en.us
http://grouper.text.en.us
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(x) = Arguments tab
-registry -check -noprompt
Program arguments:

Classpath tab
Highlight User Entries and click ‘Advanced…’
Add the ‘conf’ folder to the classpath

Click ‘Apply’
Click ‘Run’

Run RegistryReset with ‘addSubjects’ as an argument to add sample subjects:

Right click RegistryReset in grouper project explorer
Select ‘Run as’ and then ‘Run Configurations…’

Name: RegistryReset addSubjects
(x) = Arguments tab

Program arguments:
addSubjects

Classpath tab
Highlight User Entries and click ‘Advanced…’
Add the ‘conf’ folder to the classpath
Click ‘Apply’

Click ‘Run’

Query the subjects table from the Eclipse Data Source Explorer to see the added subjects:

Run grouper-ui in Eclipse with Tomcat

Now that we have a Grouper database and some test subjects, the next step is to add the grouper-ui/webapp directory to the Eclipse Tomcat launcher so 
we can run and debug the grouper-ui.

Add Tomcat server to Eclipse:

Eclipse -> J2EE Perspective -> Servers Tab
Click “No servers are available. Click this link to create a new server…”

Select 'Tomcat v8.5'
Select your tomcat installation directory
Select your JRE
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Add grouper-ui web module to Tomcat Server

Double click on Tomcat v8.5 at localhost [Stopped, Republish] to access configuration panel
Click on ‘Modules’ tab, click ‘Add External Web Module…”

Configure Server Location

Select ‘Use Tomcat installation (takes control Tomcat installation)

Configure Tomcat Server Working Directory to direct Grouper logs
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Servers tab -> Overview -> click on “Open launch configuration”
(x)= Arguments tab
Working directory:

Select grouper-ui/webapp/WEB-INF
Choose Other
Click Workspace…

Grouper logs will now show up under ../grouper-ui/webapp/WEB-INF/logs

Create Grouper Users in tomcat-user.xml

Add GrouperSystem and test.subject.0 through 9 to tomcat-user.xml

Add the following to ../apache-tomcat-8.5.50/conf/tomcat-users.xml 

<role rolename="grouper_user"/>
<user username="GrouperSystem" password="" roles="grouper_user"/>
<user username="test.subject.0" password="" roles="grouper_user"/>
<user username="test.subject.1" password="" roles="grouper_user"/>
<user username="test.subject.2" password="" roles="grouper_user"/>
<user username="test.subject.3" password="" roles="grouper_user"/>
<user username="test.subject.4" password="" roles="grouper_user"/>
<user username="test.subject.5" password="" roles="grouper_user"/>
<user username="test.subject.6" password="" roles="grouper_user"/>
<user username="test.subject.7" password="" roles="grouper_user"/>
<user username="test.subject.8" password="" roles="grouper_user"/>
<user username="test.subject.9" password="" roles="grouper_user"/>

Run Grouper from Eclipse

Start Tomcat from Eclipse by selecting the server under the Servers tab and clicking the green ‘Run’ button.

Grouper UI should be available at . You should be able to log in with GrouperSystem or any of the test subjects and no http://localhost:8080/grouper
password.

http://localhost:8080/grouper
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Debug Grouper from Eclipse

Set a breakpoint in UiV2Main.java line #114
Start the server in debug mode
Login and try to search in the Grouper UI

This should hit the breakpoint in Eclipse and allow you step through the code.

Congrats! You now have a working Grouper development environment. Now go check out  and then pick up some Grouper developers coding standards JI
!RAs

https://spaces.at.internet2.edu/display/GrIntDev/Grouper+developers+coding+standards
https://todos.internet2.edu/projects/GRP/issues/
https://todos.internet2.edu/projects/GRP/issues/
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