Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • For Registry v1.0.x and earlier, PHP 5.2.8 or later is required.
    • (warning) The GitHub Provisioning Plugin requires PHP 5.4. It may be necessary to delete this plugin to use an earlier PHP version.
    • PHP 7 is not supported.
  • For Registry v2.0.0 through v4.0.2, PHP 5.4 or later is required.
    • PHP 7 is supported. The use of PHP 7.0.10 or later is recommended, as earlier version have known bugs that may cause segmentation faults under Apache.
      • PHP 7.1 and 7.2 are supported starting with Registry v3.1.0.
      • PHP 8 is supported starting with Registry v4.0.2.
    • The Crowd Provisioning Plugin requires PHP 7.0 or later.
    • The LDAP Source Plugin requires PHP 5.6 or later.
    • The Password Authenticator Plugin requires PHP 7.0 or later (PHP 5.5 or later for Registry 3.1.x).
  • For Registry v4.1.0 and later, PHP 7 or later is required.
    • (warning) PHP 8.1 is not yet fully supported. (CO-2468)
  • For Registry v5.0.0 and later, PHP 78.0.42 or later will be required.

...